Wednesday, December 27, 2006

Oracle Apps on Mozilla Firefox

You actually don't need to install JInitiator (jinit 1.3.1.21) to run Oracle Applications on Firefox if you already installed the Sun JRE 1.4.2 and above. You will need to edit pluginreg.dat

On Windows, that file is located at %APPDATA%\Mozilla\Firefox. Make a copy of the existing one first in case something goes wrong.

Search for NPJava14.dll because Oracle runs on Java 1.4. This will appear whether you have installed Java 5 or 6.

You will need to add the following line to at the end of the plugins.

6|application/x-jinit-applet;version=1.3.1.21|Java||$

Then update the count at the top of the section. Your modified pluginreg.dat will look like:

C:\Program Files\Java\jre1.5.0_09\bin\NPJava14.dll|$
|$
1160594743000|1|5|$
Java Plug-in 1.5.0_09 for Netscape Navigator (DLL Helper)|$
Java(TM) 2 Platform Standard Edition 5.0 Update 9|$
7
0|application/x-java-applet;version=1.4.2|Java Applet||$
1|application/x-java-bean;version=1.4.2|JavaBeans||$
2|application/x-java-applet;version=1.4.1|Java Applet||$
3|application/x-java-bean;version=1.4.1|JavaBeans||$
4|application/x-java-applet;version=1.5|Java Applet||$
5|application/x-java-bean;version=1.5|JavaBeans||$
6|application/x-jinit-applet;version=1.3.1.21|Java||$

Just replace the | with : if you're in Linux. Run Firefox and you're good to go.