Thursday, April 11, 2013

PDI Kettle 4.4.0 Missing MySQL and Oracle

Pentaho Data Integration (PDI) Kettle does not include all database JDBC drivers by default beginning with version 4.4.0. Oracle and MySQL, in particular are have been taken out. That means all your transformations and jobs that access those databases will not run until you copy the jdbc drivers to the libext folder.

The following table shows the comparison between an older version of PDI. The highlighted rows are no longer bundled by default, so you'll have to copy the drivers over from an previous version or download from the database vendor's website.

Post a Comment